[ROM] [Storage][Netflix] Adoptable Mi Rom by gabrielgagz v1.2

Discussion in 'Razer Forge TV' started by gabrielgag, Dec 9, 2016.

  1. ncarneiro

    ncarneiro New Member

    Used the Forge today the entire day and found that the stuttering is not Netflix only, it happens from time to time in youtube, games and even in the launcher. Maybe I got a Faulty unit.
     
  2. xamindar

    xamindar New Member

    I don't need the adoptable storage feature so I did the following:
    I just finished a full reflash of my forge. Installed the official rom, set it up and only installed kodi, syncthing (to get all my files back on it), and an old es explorer file manager version. Then I flashed twrp recovery, booted into it, and flashed the forgeflex and supersu patches. Booted up my fresh forge and installed netflix. Started a movie, and it does the same thing. It still has constant stalls while playing.

    So this is not only an issue with gabrielgagz modifications, netflix does it no matter what.
     
  3. BoogalooShrimp

    BoogalooShrimp Active Member

    Fyi I got my Netflix to work again (video stutter remains)

    Dunno if it helps anyone else but I was getting the same tvq pm 100 "cannot play title right now" issue after the first few seconds.

    I also dunno if all of the following steps are required, but I did it all to be sure I covered every situation, and it worked !!

    Sign out of Netflix on the forge. Delete app data and cache.

    Sign into Netflix NOT on the forge (I used a PC).

    Find the program you were last successfully able to watch. Delete that from your recently viewed list (account, profile, viewing activity)
    ** I didn't know exactly which one so I deleted a week's worth of history before and after the issue**

    You will get a message that it may take up to 24 hours for the deletion requests to be processed.

    Once all is done, sign back into forge version of Netflix. Play a video. FINGERS CROSSED IT WORKS FOR YOU TOO!!!

    ***Side note and alternative - create a new profile... I was able to watch programs on all of my other profiles except the primary one without going through the above steps***
     
  4. Xen0sys

    Xen0sys New Member

  5. Knaart

    Knaart New Member

    Is it possible to clear all the files when installing the rom? My Kodi settings are still there when doing a factory reset.
     
  6. g|itch

    g|itch Member

    Installing the ROM won't wipe out your existing data. You either have to go through the Android TV settings to perform a factory reset after installing the ROM, or choose the option when in TWRP doing the flashing.

    Unfortunately it seems that my Forge is coming to its end of days. I keep getting static-like momentary scrambles and everything goes pinkish until I switch the HDMI input and switch back. Nothing else is giving me the problem on my TV, and the problem followed it while switching HDMI ports. Looks like the worst tech investment I ever made is in its final throws of implosion.

    It's too bad... It's finally been a really solid Kodi box since the instability issues were finally resolved with Android M... 1.5 years into its existence. This is most definitely the final piece of Razer hardware I will ever consider purchasing again now that I know what kind of company they are. Lies, misrepresentations, poor support, no transparency, and of course, complete and total abandonment. This thing had the power to take on the Shield in so many regards, but thanks to Razer's ineptitude, it'll simply go down as the worst possible Android TV device nobody should have ever bought.

    I'll probably lurk here and there, but chances are I'll swap out my Forge for one of my other Kodi boxes in the next few days, and that'll be the end for my time on these forums.

    Cheers guys, it's been fun seeing the community come together to (try to) make something respectable out of this consumer insult.
     
    Last edited: Mar 25, 2017
    BoogalooShrimp likes this.
  7. BoogalooShrimp

    BoogalooShrimp Active Member

    Haha I'm right behind you man. My Netflix went kaput again and I'm tired of all the fiddling around. I just bought a couple of guestroom TV's so I will soon relocate the two forge TV's I have in those rooms (I hate guests, so might as well torture them while they are here lol).

    This will be the last Razer purchase I ever make as well. Nothing about this device including the extremely overpriced controller is compelling enough to give me any confidence about their other products.
     
    goodhur and g|itch like this.
  8. gabrielgag

    gabrielgag Active Member

    Too bad to read this guys....but i'm here to say that the Adoptable Mi Rom it's dead...i'll not update it anymore.
    But something better is coming...i've been working alot in a new rom (still based in marshmallow, but builded from sources) wich i think will laid the foundations for futures unnoficial updates....but, right now it's on early and super alpha stage...i hope publish some better news soon...

    @g|itch you did alot for this small community, i hope you stay a little more...in a future i'll need beta testers :)
     
    Last edited: Mar 31, 2017
    g|itch and goodhur like this.
  9. g|itch

    g|itch Member

    Good news, everyone!

    Seems like a bad HDMI cable for my Nintendo Switch was causing a short or something when the system was being docked or sending a cec "still alive" signal.

    Basically, everything else connected to my TV was good at shielding from it, but the Forge was full on glitching out each time it happened. Hasn't come back since I noticed and changed the Switch cable. My Forge has received a stay of execution for the time being!
     
  10. BoogalooShrimp

    BoogalooShrimp Active Member

    Haha nice glad it worked out for you. I'm still done with it. Just holding off until a sale comes on for shield TV or possibly fire TV and I'll pull the trigger. Aside from Netflix and some minor squabbles I really don't have an issue with the forge, but I have no respect for or trust in Razer so I will part companies with their product at my soonest convenience.
     
    xanderten50 likes this.
  11. Wienersoup

    Wienersoup Member

    So i cant get netflix to work. And thats fine. I dont need it on my forge. What i do want however is to ditch this mibox trickery and just go back to adaptable storage and cortex. I think theres some softwares that wont work my forge in that custom rom. Some games that download fine from play but dont actually play, and some games now not even showing up anympre prolly because they dont like miboxes. So what i do to restore that?
     
  12. gabrielgag

    gabrielgag Active Member

    If you are in 1.2 you shouldn't have problems with Play Store. Anyway if you want to go to closest to stock, but with storage enabled, you can flash stock rom an then the adoptable boot image...
     
  13. roymathieu

    roymathieu New Member

    FYI I just reflashed the stock 6.0.1 rom plus forgeflix.zip and I still get video stuttering in Netflix (1-2 second freezes every minute or so). I tried Netflix Ninja v 2.5, 3.2 and 4.0 apks and I always get the same stutters.
     
  14. roymathieu

    roymathieu New Member

    I'm wondering, has anyone tried to flash the stock 5.1.1 rom and apply forgeflix.zip on it? I don't remember noticing any improvement between 5.1.1 and 6.0.1. Having stutter-free video would have more value for me than the unexistent features of Android M.

    Edit: I just tested with 5.1.1. No luck, after installing the forgeflix.zip, the device wont boot anymore. It's probably configured to work only on 6.0.1. I'm now trying Gabriel's 1.0 rom just in case.

    Edit2: Same stuttering with Gabriel's 1.0 rom :slightly_sad: I was hoping no Cortex would free up enough ram to avoid the stutters, nope.
     
    Last edited: Apr 26, 2017
  15. gabrielgag

    gabrielgag Active Member

    I hope my new rom solve this issue. Probably i'll need testers with Netflix suscription...
     
  16. roymathieu

    roymathieu New Member

    I'll gladly test it when it's ready. When do you think it'll be ready?
     
  17. gabrielgag

    gabrielgag Active Member

    The build.prop from marshmallow will never work on lollipop. That's why you get a bootloop. If you wanna do it manually you can flash lollipop, then super su, and then edit build.prop in line "ro.nrdp.modelgroup"
     
  18. gabrielgag

    gabrielgag Active Member

    Soon, i hope...I got almost all working, include casting (DRM), so probably Netflix should work...
    But the rom it's still on alpha stage due to several annoying "mini bugs"...But wil come with cool features!
     
    g|itch likes this.
  19. Knaart

    Knaart New Member

    Nice, but does it still have Cortex?
     
  20. gabrielgag

    gabrielgag Active Member

    Yes Cortex works....the rom it's still based on MarshMallow. In a future if a choose go for Nougat or Oreo, probably Cortex will not work anymore...i can't do nothing about this....
     
    Knaart likes this.