Razer zSilver will be undergoing scheduled maintenance on Nov 21 2017 ~ Dec 1 2017 for us to serve you better. Learn more.

The New Razer Blade (7th Gen Intel i7)

Discussion in 'Systems' started by Razer|Technokat, Feb 13, 2017.

  1. vistar

    vistar Active Member

    If you haven´t rolled back for whatever reason, the workaround is to put the laptop to sleep using the power button, then close the lid.
     
  2. Feromoon

    Feromoon New Member

    Does anyone found alternative for razer's A/C adapter?
    I want to buy it, but unfortunately it doesn't sells in Thaland =(
     
  3. Joikansai

    Joikansai Well-Known Member

    How annoying seeing this issue anywhere. Hope the fix come soon. Anyway did you guys tried to see if problems still exist after uninstalling synapse, maybe its synapse related issue? Seems the support pointed it in other forum, maybe worth a try.
     
    vistar likes this.
  4. vistar

    vistar Active Member

    Not a synapse issue, since the issue is present even after a clean install before installing synapse and the touchpad drivers.
     
    Last edited: Oct 22, 2017
    Joikansai likes this.
  5. davidmthekidd

    davidmthekidd Active Member

    Hopefully Razer or Microsoft will fix this bs issue, So annoying.
     
  6. vistar

    vistar Active Member

    Support did say they are working on it.
     
  7. Nofacekiller

    Nofacekiller New Member

    I'm really disappointed that it took so long to release the 4K blade...but I can't justify selling a 1080p kaby blade just to upgrade to a nicer screen....guess I have to wait for Volta.
     
  8. Joikansai

    Joikansai Well-Known Member

    I thought also the same, but combination between GPU, CPU and 1080p screen, is perfect to fit FHD games needs, if you use its 4k screen on gaming you probably want to buy the core and high end GPU. The weight is also remarkable for me.
     
    davidmthekidd likes this.
  9. davidmthekidd

    davidmthekidd Active Member

    Not just that, but I'd still prefer 7 Hours of battery over 4, at 14" 4K is plain stupid. More selling gimmicks in my opinion, All I want is OLED on my laptop, I cant wait for a better display on the 1080p model. I cant stand the Back Light Bleed on IPS, let alone the color inconsistency and ms lag.

    Also, RAZER, please add a NFC chip near the track pad, I'd like to quickly turn on and connect my wireless headphones without going onto windows audio settings.
     
    Joikansai likes this.
  10. Nofacekiller

    Nofacekiller New Member

    14" 4k isn't stupid for text, photo, or video. There is a clear difference at normal viewing distances. Not to mention the colors are much nicer. 4k at 14" is only "stupid" for games honestly. But you can play at 1080p even on a 4k screen. Can't wait for 1080p to die out.
     
  11. Joikansai

    Joikansai Well-Known Member

    You’re right for content creator purposes or media consumption for those who has great eyes;) Yes you do can play 1080p on 4K screen with slightly low FPS due downscaling, it has better scaling than previous 1800p though.
    Well it’ll be loong wait for gaming, for media consumption or TV maybe.
     
  12. Salmoneasyhome691

    Salmoneasyhome691 New Member

    Thanks once again for your advice back then Joikansai. Have my blade back since a couple of weeks now and everything is fine. As the frame was not attached correctly on my blade which was the reason for sending it in they equipped my blade with a brandnew screen.

    Also I had added a note concerning the clicking noise I noticed and described but unfortunately they did not respond directly to that. However it passed all the performance tests / heat tests without any issue which took my worries and probably they checked it but just found nothing special about it. As the noise is nothing spectacular, I noticed every other notebook I met lately had much more outstanding noises in use. The only thing for me was that I did not remember hearing it from the beginning, but I indeed did install the GeForce client only a few weeks postponed which could be a reason.

    Maybe this is help to anyone experiencing anything similar.
     
    Joikansai likes this.
  13. Hello. I need help. When my windows 10 1703 update to 1709. After update i have problem whith touchpad, keyboard, usb and usb mouse in power mode(a lot of lags, freez for 1 second(mouse, keyboard, usb, system not stable). In battery mode after sleep touchpanel dosent work (keybord, usb and usb mose not stable) :slightly_sad: but work after restart. this is not hardware problem i see this problem in 2 razer blade 14 in the store. But when i setup 1703 all work fine but this update(1709) back again :slightly_sad: on my second machine xiaomi air 13 all work good on 1709. What i need to do for fix this bug? A cant use my laptop whith this problem. I setup clean 1709 problem same. I fount last drivers(intel-chipset-manager-video..., nvidia, last killer drivers bleutooth and wifi) for all hardware and problem is same. Whait for fix? When fix come? Or what? RAZER HELP ME!!!

    Razer Blade 14 2017 (1tb, FHD)
     
  14. Joikansai

    Joikansai Well-Known Member

    I have same rigs with you Blade 14 2017 and xiaomi Air, my Air 13 also working with no issues on 1709, if you could wait wait for 14th November Microsoft update, they mentioned the fix on other forum, if you can’t wait roll it back to 1703 and see other users if the fix solved the issue.
     
  15. maverickar15

    maverickar15 New Member

    Still have my Razer Blade. Dropped nail clipper on the laptop with it open so ended up with a scratch :slightly_sad: but other than that running fine.

    I'm sure people here are already familiar but with later versions of MSI Afterburner, if you open voltage vs frequency graph using CTRL+F it will allow you to undervolt GPU within limits.

    Was getting around 9792 Firestrike / 3836 Timespy with
    -Stock GPU clock at 1708 MHz at 800mV (made a flat line. I believe stock curve only goes up to 1708 MHz at around 912 mV, so that is around 112 mV undervolt I think...)
    -Memory overclocked by 350 MHz.
    -Max 80C on GPU, 76C on CPU (CPU also undervolted by 145mV but all stock clock and turbo settings)

    I know a lot of people like to run with at least 400 MHz overclocked on memory but my 1060GTX gets very unstable, so I'm sticking with only 350 MHz boost on memory.


    I usually get something like 9300-9400 with just CPU undervolted and nothing else touched on GPU side. It is nice to get free 300-400 points just from setting 1708 MHz at 800mV instead of 912mV. I wish Afterburner will let you change frequency settings at a lower voltage than 800mV.

    I was getting very close to 10,000 Firestike / 4,000 Timespy score running at around 1730+ MHz core clock at 800mV but I was unwilling to actually overclock anything other than GDDR to get better scores, as I want to keep this laptop lasting as long as possible.


    Lastly...does anyone know why I could undervolt my CPU to -160mV and run Prime95 and be fine but when actually playing games I have to back it down to -145mV to be completely stable? This makes about 2-3C and 2W different running at max speed so it is somewhat tangible, so I'd like to undervolt as much as I can...
     
    Last edited: Nov 14, 2017 at 6:19 AM
  16. Joikansai

    Joikansai Well-Known Member

    https://www.3dmark.com/3dm/20820726 ;)
     
  17. maverickar15

    maverickar15 New Member

    Very nice score! I think 9962 was as close as I got pushing at around 1890 MHz.

    What GPU core / Memory clock were you running at? It says 1,100 MHz but somehow I don't believe it :)
     
  18. Joikansai

    Joikansai Well-Known Member

    You need to disable ASPM through Bios. For Kabylake model you need to moding the Bios, there’s already tutorial about it on YouTube or Reddit I think. I got also around same as you but now I put all back on stock because with around 9700 is already enough for me, and don’t want to push the GPU too hard for better longevity.
     
    Last edited: Nov 14, 2017 at 4:18 AM
  19. maverickar15

    maverickar15 New Member

    Eh, ~9700 also enough for me, probably not modding anything serious. In fact I have enough performance - if I can keep the blade from going into one step before the "full cooling" fan speed then I can game comfortably and I'd rather stay there.

    I really don't want to overclock anything really, I'm just looking for ways to undervolt as much as possible while maintaining the stock frequency as it is fast enough.

    Also, it looks like I was wrong with the clock info... 1708 MHz is for 1060 desktop GPU, not mobile. Mobile is 1670 MHz.
     
  20. Joikansai

    Joikansai Well-Known Member

    Don’t look at clocks info at 3D Mark at benchmarking it’s not always right, I had 500 MHz and score was better than higher level.