What's up with the site/store?

Discussion in 'General Discussion' started by Bratatat, May 19, 2017 at 4:04 PM.

Thread Status:
Not open for further replies.
  1. Bratatat

    Bratatat New Member

    Uhm.
    None of the site is working properly for me. The razer blackwidow v2 page just gives me a 404 not found error, other pages are fully white with 1 image and 1 line of text. The address bar changes the address to "new2.razerzone.com" and none of the product pages in the store will load for me.

    What's going on? This is happening both on my iPhone, iPad and desktop; are you guys doing some updates?
    I mean.. I wanted to order a blackwidow v2 but now I can't ;(
     
  2. ARMOR_152

    ARMOR_152 Active Member

    Try clearing your cache.
     
  3. Bratatat

    Bratatat New Member

    Have you not read my post?
    How would clearing my cache help?

    http://prntscr.com/f9qajn
    These kind of errors are def. not an issue on my end. It appears that these issues are only on the EU version of the store though. I also just got this email for some reason; http://prntscr.com/f9qb62

    No, I did not just create an account or anything. Weird stuff is happening..
    @razer
     
  4. Bratatat

    Bratatat New Member

    Yes, US store is working just fine for me although the EU store isn't.
     
  5. ARMOR_152

    ARMOR_152 Active Member

    K, ya it must be something more major. This site does have some problems sometimes and clearing the cache fixes them. I just got that email too so you're not alone.
     
  6. Bratatat

    Bratatat New Member

    Why would they send an email to everyone that their account has been created? Were they hacked and is someone trying to steal personal information & passwords perhaps? :eek:

    Although.. if someone would've actually hacked into their site, they'd probably have acces to all the passwords anyways :stuck_out_tongue_winking_eye:
     
Thread Status:
Not open for further replies.