We have an important update regarding your Razer Insider account. Read more.

Win10 Creators Update broke Synapse UI

Discussion in 'General Discussion' started by divdestroyer, Apr 18, 2017.

  1. OS: Win10 Pro Creators Update (build 15063.138)
    Synapse version: latest (
    Issues: UI is missing all text and click behavior is off.

    Clicking anywhere on UI brings up empty User Menu drop-down rather than clicking where your cursor is positioned. Takes 3 clicks on the X to close the UI as first two toggle user menu open/closed.

    Uninstall/Reinstall did not resolve for me, but I found a thread elsewhere mentioning reinstall fixed things for them. Anyone else running into this?
  2. Pinkleetbus580

    Pinkleetbus580 New Member

    Yup, broke mine too I believe. I just did the Windows update yesterday and the problem with Synapse today. Synapse starts and is active in Task Manager but doesn't respond. It will open at the cloud splash screen and just stop. Looking for answers now, maybe a .net thing.
  3. Same issu, Synapse starts and is active in Task Manager but doesn't respond
  4. ThirdDegreePun

    ThirdDegreePun Well-Known Member

    I installed it and it's working no problem for me. I'm assuming you guys can't click on that settings cog and get to the 'submit feedback' section? It might be worth contacting support over it, also make sure you've got the latest version (which I'm sure you have if you've tried reinstalls)
    Fisz likes this.
  5. Does anyone have an early solution?
  6. Badgertista

    Badgertista Active Member

    Synapse is working fine here, latest version installed

    I have a fresh installation of Windows 10 Pro with the Creators Update, installed from the latest official ISO downloaded straight from MS after the update was made available.
  7. Joikansai

    Joikansai Well-Known Member

    You have the Blade 14 right? Did you also update it? If yes, is there any problems after creator Update, because i saw in Kabylake Blade 14 thread, Blades users having problems on their machine like BSOD etc after creators update which make them have to rolled it back to previous version before update.
  8. MissSwaggy

    MissSwaggy Active Member

    We would just have to wait till it gets fixed. I haven't seen any solutions to this problem so far.
  9. Yousif47

    Yousif47 Active Member

    I have no issues with the creator update whatsoever, synapse runs as always
  10. Badgertista

    Badgertista Active Member

    I have the latest Kaby Lake Blade

    On Day 1 of creators update, the GTX 1060 had issues, but NVidia released a fix a few days later. Everything is working great since then.
    I'm don't know if the fix has made it to Geforce Experience yet, I got it from their hotfix section. If the deiver available in GeForce Experience is still 381.65, well don't upgrade. You need 381.78 for it to work correctly

    Right now I don't have any issues with Windows 10 CU, Synapse, Nvidia drivers ... and I'm a heavy user (both for work and games). But I did not go the "update" path; I did a fresh install of everything, so I can't speak for people who just did the "update".
    Joikansai likes this.
  11. gskull

    gskull Member

    I have the problem where Synapse is running but will not open.
  12. I installed the last driver of geforceexperience, I reinstalled windows creator update, I put all my drivers up to date, then I reinstalled razer synapse and I still have the same problem, Razer synapse is launched, but When I want to open it nothing happens.
  13. I had the same issue. The UI was blank and I couldn't click on anything. I reinstalled Synapse and rebooted my PC, but that didn't fix the issue.

    I went online and found an older version of Synapse released in February this year, installed it, and it seems to be working fine now. Everything is back to normal.
  14. rimbaudmatthill

    rimbaudmatthill New Member

    I'm having this exact issue. Any fix yet?
  15. Blurporator

    Blurporator New Member

    @rimbaudmatthill: I am running latest Synapse ( at the moment) @ Win10 Pro build 15063.296 (fresh install) without issues. Probably your problem is related to other software present in your system.
  16. laceyboy

    laceyboy New Member

    I also have Win 10 Creator fresh installed and latest Synapse installed and I have no problem.

    Sent from my SGP771 using Tapatalk
  17. Toothbruush

    Toothbruush Member

    also experiencing the same thing just opened snypase today wanted to change colours of my firefly to the same result lol..so it is windows 10 creators update hmm

    Last edited by a moderator: Jul 17, 2017
  18. Ntinsky

    Ntinsky New Member

    I had the exact same issue.

    Uninstall Synapse
    Delete installation folder if still exists
    Delete ProgramData\Razer folder
    Download and install the .NET Framework offline installer package, version, 4.7, unless you have it already
    Reboot computer
    Reinstall Synapse

    Let me know if this works for you
  19. unique_ID

    unique_ID New Member

    Hi, any updates to this thread? I tried the above methods, none so far have worked.